我的Android进阶之旅

  • 时间:
  • 浏览:0
  • 来源:幸运飞艇_幸运飞艇官方

04-13 10:09:49.565: E/dalvikvm(354): Could not find class 'org.ksoap2.serialization.SoapObject', referenced from method......

原应有或多或少是以下十个 之一:

重启机器或多或少重启下adb

 

原应及处里土最好的办法:

'JDI thread evaluations' has encountered a problem

修改后:

org.eclipse.jdi.TimeoutException: 听候包 8 时所处超时。

 at org.eclipse.jdi.internal.connect.PacketReceiveManager.getReply(PacketReceiveManager.java:171)

 at org.eclipse.jdi.internal.connect.PacketReceiveManager.getReply(PacketReceiveManager.java:1200)

 ......

【错误信息】

Or

开发包这么Android2.2以上

ActivityManager: Warning: Activity not started, its current task has been brought to the front

  转载请保留原文地址:http://blog.csdn.net/ouyang_peng

原应及处里土最好的办法:

保存,重新启动SDK Manager.exe

current version is 8.0.1.v201012062107-82219.

原应:

[2011-01-19 16:55:04 - ApiDemos] Installation error: INSTALL_FAILED_INSUFFICIENT_STORAGE

[2011-01-19 16:55:04 - ApiDemos] Please check logcat output for more details.

[2011-01-19 16:55:05 - ApiDemos] Launch canceled!

【错误信息】

点击android下面的lint error checking ->勾选掉run full error ....如下图

Failed to fetch URL https://dl-ssl.google.com/android/repository/repository.xml,

原应及处里土最好的办法:

无法解析导入 com.renren.api.connect.android.R

Android 签名打包时总出 下面错误:

04-13 10:09:49.585: E/dalvikvm(354): Could not find class 'org.ksoap2.transport.HttpTransportSE', referenced from method......

找这么源

java.lang.IllegalArgumentException: The key must be an application-specific resource id.

[2011-04-19 10:55:11 - JavaEye Android Client] Project has no default.properties file! Edit the project properties to set one.

原应:

【错误信息】

与运行无关的错误,关掉'expressions'视图就都不能了

please update adt to the latest version

重新启动eclipse

原应及处里土最好的办法:

原应:

The constructor AlertDialog.Builder(chuanbo_detail.HttpThread) is undefined

Exception processing async thread queue

Please login to the following ......

java.lang.RuntimeException: Can't create handler inside thread that has not called Looper.prepare()

eclipse这么升级到3.6.0,我的版本是3.5.2

【错误信息】

原应及处里土最好的办法:

 this android sdk requires android developer toolkit version 10.0.0 or above.

【错误信息】

该设备这么足够的存储空间来安装程序,

原应及处里土最好的办法:

处里土最好的办法或多或少修改C:\Windows\System32\drivers\etc\hosts文件。再加一行:

【错误信息】

关闭模拟器和eclipse,执行adb kill-server命令,或多或少重试一下

[2012-09-09 00:15:34 - IpsosAutoAndroid] Proguard returned with error code 1. See console

[2012-09-09 00:15:34 - IpsosAutoAndroid] Note: there were 4 duplicate class definitions.

[2012-09-09 00:15:34 - IpsosAutoAndroid] Warning: library class android.content.res.XmlResourceParser extends or implements program class org.xmlpull.v1.XmlPullParser

[2012-09-09 00:15:34 - IpsosAutoAndroid] Warning: library class android.content.Intent depends on program class org.xmlpull.v1.XmlPullParser

[2012-09-09 00:15:34 - IpsosAutoAndroid] Warning: library class android.util.Xml depends on program class org.xmlpull.v1.XmlPullParser

[2012-09-09 00:15:34 - IpsosAutoAndroid] Warning: library class android.util.Xml depends on program class org.xmlpull.v1.XmlSerializer

[2012-09-09 00:15:34 - IpsosAutoAndroid] Warning: library class android.util.Xml depends on program class org.xmlpull.v1.XmlPullParser

[2012-09-09 00:15:34 - IpsosAutoAndroid] Warning: library class android.view.LayoutInflater depends on program class org.xmlpull.v1.XmlPullParser

[2012-09-09 00:15:34 - IpsosAutoAndroid] Warning: library class android.view.LayoutInflater depends on program class org.xmlpull.v1.XmlPullParser

[2012-09-09 00:15:34 - IpsosAutoAndroid]       You should check if you need to specify additional program jars.

[2012-09-09 00:15:34 - IpsosAutoAndroid] Warning: there were 7 instances of library classes depending on program classes.

[2012-09-09 00:15:34 - IpsosAutoAndroid]          You must avoid such dependencies, since the program classes will

[2012-09-09 00:15:34 - IpsosAutoAndroid]          be processed, while the library classes will remain unchanged.

[2012-09-09 00:15:34 - IpsosAutoAndroid] java.io.IOException: Please correct the above warnings first.

[2012-09-09 00:15:34 - IpsosAutoAndroid]  at proguard.Initializer.execute(Initializer.java:321)

[2012-09-09 00:15:34 - IpsosAutoAndroid]  at proguard.ProGuard.initialize(ProGuard.java:211)

[2012-09-09 00:15:34 - IpsosAutoAndroid]  at proguard.ProGuard.execute(ProGuard.java:86)

[2012-09-09 00:15:34 - IpsosAutoAndroid]  at proguard.ProGuard.main(ProGuard.java:492)

【错误信息】

原应及处里土最好的办法:

【错误信息】

【错误信息】

今天在配置完Eclipse和Android SDK开发环境以前,想用华为C82000手机通过USB连接电脑,并在手机上去调试,但莫名其妙总出 Adroid Adapter ADB Interface 安装严重错误,在豌豆荚手机精灵安装驱动的以前,也总出 有某种错误,上方也莫名奇妙的多装几只就好了,还没找到什么原应。

“正在启动JavaEyeApiAccessor“遇到问題。

【错误信息】

最近(2012-04-05)在打开SDK Manager.exe,更新SDK时,会总出 如下错误:

Your original request has been modified.

  "Android DDMS" is already installed, so an update will be performed instead.

  "Android Development Tools" is already installed, so an update will be performed instead.

  "Android Hierarchy Viewer" is already installed, so an update will be performed instead.

  "Android Traceview" is already installed, so an update will be performed instead.

Cannot complete the install because one or more required items could not be found.

  Software being installed: Android Development Tools 17.0.0.v201203161636-291853 (com.android.ide.eclipse.adt.feature.group 17.0.0.v201203161636-291853)

  Missing requirement: Android Development Tools 17.0.0.v201203161636-291853 (com.android.ide.eclipse.adt.feature.group 17.0.0.v201203161636-291853) requires 'org.eclipse.core.runtime 3.6.0' but it could not be found

【错误信息】

原应及处里土最好的办法:

描述 资源 路径 位置 类型

Error generating final archive: Debug Certificate expired on 12-10-18 下午12:10 IpsosAutoAndroid  未知 

Project / Properties / Java Compiler  ,查看Compiler compliance level 指定的版本号被指定为1.6,或多或少Enable project specific seetings 被勾选。

原应及处里土最好的办法:

  1. 启动 Eclipse, 或多或少进入 Help > Install New Software.

This Android SDK requires Android Developer Toolkit version 17.0.0 or above.

【错误信息】

//这么在程序中操作UI界面

原应及处里土最好的办法:

查看程序,关闭所有adb.exe

2.delete android上方的 apk,保证传输传输速率。不过试过一次后,真机好像变“聪明了”,也总出 timeout。

重启启动平板电脑机器就OK

原应及处里土最好的办法:

遇到有某种情况,都不能创建十个 default.properties文件,或多或少创建以前还是有错误,这么delete有某种project,重新import。

编辑default.properties 以前,一般会自动创建 gen 目录, 或多或少这么,也可尝试手工创建。

  作者:欧阳鹏  欢迎转载,与人分享是进步的源泉!

eclipse这么升级到3.6.0,我的版本是3.5.2

原应及处里土最好的办法:

dl-ssl.google.com在大陆封掉了

【错误信息】

 重新启动eclipse,不行励志的话 重启机器

【错误信息】

【错误信息】

 在新的程序中 public class HttpThread extends Thread {...}

【错误信息】

原应及处里土最好的办法:

并非 标明上 Java Build Path->Libraries中或多或少引用了ksoap2-android 包,或多或少这么order and export中也把该包勾选上

[2011-02-18 11:46:53] Failed to push selection: Is a directory

error: Error: No resource found that matches the given name (at 'layout_toLeftOf' with value'@id/top_send_btn'). 

1)Webservice服务器的Soap版本为1.0,可是客户端指定

requires 'org.eclipse.ui 3.6.0' but it could not be found

==================================================================================================

原应及处里土最好的办法:

Eclipse中的DDMS无法打开data文件夹下的内容,或多或少能往上方写东西

==================================================================================================

打开开源项目JavaEye Android client时出错

或多或少你想调试的以前再加 Waiting for Debugger 提示

在程序debug(运行这么问題)时调用Webservice时总出 :

进入C:\Documents and Settings\Administrator\.android 删除路径下的debug.keystore及 ddms.cfg。

【错误信息】

org.xmlpull.v1.XmlPullParserException: expected: START_TAG {http://schemas.xmlsoap.org/soap/envelope/}Envelope (position:START_TAG <{http://schemas.xmlsoap.org/wsdl/}wsdl:definitions targetNamespace='http://bo.webservice.nqbx.nq.com'>@2:2003 injava.io.InputStreamReader@44a3a7b0)

最新的Android SDK这么安装ADT 17.0.0

原应及处里土最好的办法:

3.Cleaning the project (Project->Clean),不行就重启eclipse或多或少android,很懊丧的是,重启后运行第一次都不能。第二次就开始英文英文了了更慢了,也或多或少总出 timeout

【错误信息】

android目录下这么对应的sources文件

【错误信息】

【错误信息】

Change the build target by editing the project properties (right-click on the project in Eclipse), and choose a target with at least API Level 8

4.关闭eclipse ,或多或少再重启,就ok

原应及处里土最好的办法:

【错误信息】

原应及处里土最好的办法:

调用org.ksoap2.*访问webservice时

原应及处里土最好的办法:

或多或少是或多或少引用了第三方开发包:ksoap2-android-assembly-2.4-jar-with-dependencies.jar

Android Tools->Export Signed Application Package

【错误信息】

Android使用KSOAP2调用WebService时:

不这么混淆的把混淆的proguard.cfg再加就好了

原应及处里土最好的办法:

[2012-04-10 09:45:49 - adb] ADB server didn't ACK

[2012-04-10 09:45:49 - adb] * failed to start daemon *

原应及处里土最好的办法:

source not found

[2011-03-09 15:21:34 - Info] Failed to install Info.apk on device '?': Unable to open sync connection!

[2011-03-09 15:21:34 - Info] java.io.IOException: Unable to open sync connection!

[2011-03-09 15:21:34 - Info] Launch canceled!

查看程序,关闭所有adb.exe 

重启eclipse

【错误信息】

 这么访问到网络,可是,在AndroidManifest.xml中,这么进行如下配置: 

<uses-permission android:name="android.permission.INTERNET" />

requires 'org.eclipse.core.runtime 3.6.0' but it could not be found

原应及处里土最好的办法:

原应及处里土最好的办法:

原应及处里土最好的办法:

  原应及处里土最好的办法:

安装android sdk时:

[2011-01-19 16:39:10 - ApiDemos] WARNING: Application does not specify an API level requirement!

[2011-01-19 16:39:10 - ApiDemos] Device API version is 8 (Android 2.2)

如下是有问題的代码: 

在proguard.cfg中增加一行

-ignorewarnings

导入android源码有错,R.java文件这么自动生成处里土最好的办法

连接真机调试的以前或多或少连接太大没响应就会总出 timeout

【错误信息】

点击Debug 运行 结果模拟器时不时会弹出Waiting for Debugger 或多或少程序又都不能正常运行

 -= warning! =- A folder failed to be renamed or moved. On Windows this typically means that a program Is using that Folder (for example Windows Explorer or your anti-virus software.) Please momentarily deactivate your anti-virus software. Please also close any running programs that may be accessing the directory 'C:\android\android-sdk-windows/android-sdk-windows/too!s'. When ready, press YES to try again.

Adroid Adapter ADB Interface 严重错误

Current version is 15.0.0.V201110251216-213216.

[2011-03-04 09:25:12 - ActivityMain]: Dx

UNEXPECTED TOP-LEVEL EXCEPTION:

java.lang.IllegalArgumentException: already added: Lorg1/apache/commons/codec/net/RFC1522Codec;

[2011-03-04 09:25:12 - ActivityMain]: Dx at com.android.dx.dex.file.ClassDefsSection.add(ClassDefsSection.java:123)

[2011-03-04 09:25:12 - ActivityMain]: Dx at com.android.dx.dex.file.DexFile.add(DexFile.java:143)

.....

下图点击window->preferences如下图

Exception processing async thread queue

 

【错误信息】

  2. 在 Available Software 对话框里,点击 Add....

Updates ADT 17.0.0时提示:

原应及处里土最好的办法:

这么连接至VM

 [2012-04-13 17:46:27 - IpsosAutoAndroid] Failed to install IpsosAutoAndroid.apk on device '?': timeout

[2012-04-13 17:46:27 - IpsosAutoAndroid] Launch canceled!

原应:

原应:

连接这么手机虚拟机

http://www.eoeandroid.com/thread-114519-1-1.html

原应及处里土最好的办法:

2)String serviceUrl = "http://200.200.200.11:20000/nqbx/service/InqBxWebService?wsdl";

在UI主程序之外是无法对UI组件进行控制的。或多或少你这么在新程序任务完成以前利用各种土最好的办法先UI主程序发送消息通知任务完成从而来显示各种提示消息。

程序间通信土最好的办法有多种,常用的是用handler来传递消息。

 

【错误信息】

或多或少关闭

下载对应的SDK Sources后,倒入\android-sdk-windows\sources 目录下就OK了!

原应及处里土最好的办法:

【错误信息】

Eclipse的android开发插件版本匮乏,应该下载ADT-10.0.0,或多或少

Cancel跳过提示

1.在window-》prensent....-》android-》设置ddms的timeout时间。有某种是就最有效、最简洁的。

[2011-03-04 09:25:12 - ActivityMain]: Dx1 error; aborting

[2011-03-04 09:25:12 - ActivityMain] Conversion to Dalvik format failed with error 1

打开eclipse总出 如下错误:

拔掉连接线,运行程序还总出 如下问題:

程序中构造消息:

重启eclipse即可

java.lang.RuntimeException: Can't create handler inside thread that has not called Looper.prepare()

http://javaeye-android-client.googlecode.com/svn/trunk/

Unable to open stack trace file '/data/anr/traces.txt': Permission denied

增加十个 弹出窗体:

调试的以前:

header_questionitemlist.xml /IpsosAutoAndroid/res/layout 第 27 行 Android AAPT Problem

重启拔插手机连接线

【错误信息】

 [2012-04-09 17:14:49 - Info] ------------------------------

[2012-04-09 17:14:49 - Info] Android Launch!

[2012-04-09 17:14:49 - Info] Connection with adb was interrupted.

[2012-04-09 17:14:49 - Info] 0 attempts have been made to reconnect.

[2012-04-09 17:14:49 - Info] You may want to manually restart adb from the Devices view.

如下:

原应:

可用的下载地址:http://download.csdn.net/detail/merrido/41694200,

原应及处里土最好的办法:

android Debuger 总出 :"Waiting for Debugger - Application XXX is waiting for the debugger to Attach"

【错误信息】

【错误信息】

或多或少再用Help-> install new software->Add -> Name: ADT   Archive:取舍ADT 17.0.0.zip

亲戚亲戚亲们儿都会 为项目开发成功而喜悦,但可不知成功的路上是会时不时出错的,下面是我碰到的或多或少错误集合!

转载于:http://blog.csdn.net/sheshou2/article/details/6152988

【错误信息】

那我目录或多或少有pkg_3.apk的文件夹,再copy十个 pkg_3.apk安装文件时总出 问題,处里土最好的办法,先删除掉pkg_3.apk的文件夹

【错误信息】 

Url指的是你的webservice的地址.一般都会 以***.wsdl或多或少***.?wsdl开始英文英文了的...或多或少.这么注意的是..要再加上方的.wsdl或多或少.?wsdl

【错误信息】

Unable to open stack trace file '/data/anr/traces.txt': Permission 多见于有某种Activity你这么在AndroidManifest.xml中注册,就会报那我的错误。

[2012-04-08 17:42:24 - JavaEye Android Client] ------------------------------

[2012-04-08 17:42:24 - JavaEye Android Client] Android Launch!

[2012-04-08 17:42:24 - JavaEye Android Client] The connection to adb is down, and a severe error has occured.

[2012-04-08 17:42:24 - JavaEye Android Client] You must restart adb and Eclipse.

[2012-04-08 17:42:24 - JavaEye Android Client] Please ensure that adb is correctly located at 'C:\android\android-sdk-windows\platform-tools\adb.exe' and can be executed.

通过软件获取ROOT权限

[2012-04-10 09:53:200 - ApiDemos] ------------------------------

[2012-04-10 09:53:200 - ApiDemos] Android Launch!

[2012-04-10 09:53:200 - ApiDemos] The connection to adb is down, and a severe error has occured.

[2012-04-10 09:53:200 - ApiDemos] You must restart adb and Eclipse.

[2012-04-10 09:53:200 - ApiDemos] Please ensure that adb is correctly located at 'C:\android\android-sdk-windows\platform-tools\adb.exe' and can be executed.

不影响正常运行。在AndroidManifest.xml文件中这么加API的版本号,在<manifest> </manifest> 之间加<uses-sdk android:minSdkVersion="3"></uses-sdk>

requires 'org.eclipse.core.runtime 3.6.0' but it could not be found

原应及处里土最好的办法:

更新SDK时错误信息:

【错误信息】

打开Eclipse 提示安装ADT 17

调用Webservice时总出

这是 JavaEye 网站基于 Android 平台的客户端软件,可用以阅读动静、帖子、闲谈, 收躲, RSS 等功用。

android低版本工程(如1.5)倒入高版本环境中(如2.2)或多或少会上述错误,处里土最好的办法如下:

1。 或多或少不修改android sdk版本,则使用project clean 命令作用于某工程即可。

       (该处里土最好的办法或多或少在高版本中兼容了低版本工程,未真正意义上的升级)

2。 或多或少修改android sdk版本,则这么以下几只步骤:

       1)修改SDK

             取舍工程,build path --> configure build path ---> library 删除引用的低版本SDK,

             或多或少add External JARs,取舍高版本SDK,OK,保存

        2)修改classpath文件 

             该文件或多或少所处该项: <classpathentry kind="lib"   path ="你所指定的高版本的地址"

             把她修改成<classpathentry kind="con" path="com.android.ide.eclipse.adt.ANDROID_FRAMEWORK" />

        3) 修改AndroidManifest.xml

             在AndroidManifest.xml文件中,application标签后再加<uses-sdk android:minSdkVersion="3"></uses-sdk>

        4) 修改default.properties(有点痛 要)

              该文件最后一行(前面没用#的)target=android-3 该成target=android-8,保存。

        再看看你的工程和新建的android 2.2的工程特性就一样了。

[2012-08-22 17:21:53 - IpsosAutoAndroid] Project has no project.properties file! Edit the project properties to set one.

[2012-08-22 17:22:16 - IpsosAutoAndroid] Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools > Fix Project Properties.

SoapSerializationEnvelope envelope = new SoapSerializationEnvelope(SoapEnvelope.VER11);

Export aborted becase fatal lint errors were found.

These are listed in the Problems view. Either fix these before running 

Export again, or turn off "Run full error check when exporting app" in 

the Android > Link Error Checking preference page

【错误信息】

这里可这么用常规土最好的办法安装有某种 ADT 17.0.0.zip 文件, 首先得解压有某种文件,将上方的文件夹覆盖掉Eclipse安装目录下的文件夹。

【错误信息】

出错

Cannot complete the install because one or more required items could not be found.

  Software being installed: Android Development Tools 17.0.0.v201203161636-291853 (com.android.ide.eclipse.adt.feature.group 17.0.0.v201203161636-291853)

  Missing requirement: Android Development Tools 17.0.0.v201203161636-291853 (com.android.ide.eclipse.adt.feature.group 17.0.0.v201203161636-291853) requires 'org.eclipse.core.runtime 3.6.0' but it could not be found

JDI thread evaluations

启动Eclipse时总出 :

Site Authentication

或多或少是程序中缺少资源文件例如的

 重启eclipse

原应及处里土最好的办法:

原应及处里土最好的办法:

安装ADT 17.0.0时,提示:

【错误信息】

原应及处里土最好的办法:

Android Packaging Problem

原应及处里土最好的办法:

reason: Connection timed out: connect

 java.lang.NoClassDefFoundError: org.ksoap2.serialization.SoapObject

1, 复制 tools目录

为十个 新的目录 tools-copy ,此时在android-sdk-windows 目录下有十个 目录 tools 和 tools-copy

2, 在tools-copy目录以管理员身份运行 android.bat ,那我应该 都不能正常 update all 了

3.重新运行SDK Manager.exe.问題处里!

Fri May 04 16:27:46 CST 2012

Internal error logged from JDI Debug:

Please update ADT to latest version.

用手机调试运行总出 :

【错误信息】

另外自定义消息:

【错误信息】

VER11改为VER10

抛出IllegalArgumentException的原应就在于key不唯一,正确代码如下:

该手机或多或少启动了相同名字的应用,关闭以前再试!

如下图,我这么乎 为甚在么在,最新的SDK更新API 14/15带有Sources for Android SDK,而以前的版本的源码就不更新,懊丧!

AndroidManifest.xml配置中加入android:installLocation="auto"总出 错误:

error: No resource identifier found for attribute 'installLocation' in package 'android'

java.net.SocketException: Permission denied (maybe missing INTERNET permission)

【错误信息】

【错误信息】